IE11 Unternehmensmodus – sites.xml


Wenn ich mich bei meinen Kunden so umsehe, ist die Nutzung des Internet Explorers 11 (IE11) mit älteren Oracle EPM-Versionen nach wie vor ein Thema, um nicht zu sagen, „ein heißes Eisen“. Ist die Unterstützung des IE11 in der aktuellen EPM-Version 11.1.2.4 sowie den gepatchten Versionen 11.1.2.3.500 und 11.1.2.500 uneingeschränkt gegeben, erfordern ältere Versionen den „Unternehmensmodus“.

Dieser simuliert im IE11 eine Umgebung, in der auch ältere, für IE8 / IE10 entwickelte Anwendungen genutzt werden können.

Der Unternehmensmodus war schon Thema in mehreren Beiträgen, s. siehe Beiträge IE11 Enterprise-Mode-Patch 11.1.2.3.700 und IE11 und EPM-System 11.1.2.2.500 oder 11.1.2.3.500.

Anlass meines neuen Beitrags ist aber folgende Situation bei einem Kunden:
Der Kunde ist erfahrener Hyperion-Anwender und kennt die IE11-Problematik, deshalb wird der IE11 für EPM 11.1.2.3 (ohne 700er Patch) im Unternehmensmodus betrieben.

So weit so gut, müsste eigentlich alles laufen, oder?

Leider nicht, Anwender meldeten sich, sie kämen auf die eine EPM-Umgebung (Produktion), aber nicht auf eine andere EPM-Umgebung (Entwicklung). Auf der Produktion ist die Anmeldung am Workspace erfolgreich, auf der Entwicklungs-Umgebung nicht, dort poppte die bekannte Meldung „Unsupported Browser“ auf.

Wie kann das sein, wo doch der IE11 bereits im Unternehmensmodus läuft?

Die Ursache ist so schnell gefunden wie gelöst:

Der Unternehmensmodus wird zentral eingestellt. Dabei wird auf eine Liste verwiesen (Standard-Einstellung: sites.xml), die alle Seiten / Anwendungen / URL enthält, die im Unternehmensmodus geöffnet werden sollen.

Weitere Informationen gibt es bei Microsoft TechNet. Hier ein Beispiel, um unseren Blog im Unternehmensmodus zu öffnen:
IE11-Sites-xml
Um ganz sicher zu gehen bzw. wenn es sehr viele URL zu pflegen gibt, bietet es sich an, ein Microsoft-Utility herunterzuladen und damit eine fehlerfreie sites.xml zu erstellen. Sie finden das Utility hier.

Zurück zum Problem meines Kunden:
In der Regel gibt es einen lokal installierten IE-Browser, mit dem man sich auf die verschiedenen Umgebungen (hier: Produktion und Entwicklung) verbindet. In der Sites.xml müssen natürlich alle URL eingetragen werden, die im Unternehmensmodus geöffnet werden sollen, in diesem Fall fehlte die Workspace-URL für die Entwicklungs-Umgebung.

Sofort, nachdem diese URL in Datei sites.xml eingetragen wurde, konnten sich die Anwender erfolgreich auch an der Entwicklungs-Umgebung anmelden.

Übrigens: An diesem Symbol erkennt man, ob eine Seite im Unternehmensmodus geöffnet wurde oder nicht
IE11-Unternehmensmodus-Symbol
nach oben

Veröffentlicht unter EPM & BI, Installation, Konfiguration & Tuning Getagged mit: , ,

Schreibe einen Kommentar